Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

turning off Centerlines for pipes

goldlab

New member
I have tried putting them on layers , setting the enviroment to not show pipe centerlines, and finally erasing them. I can find no way to turn off the centerlines created by the pipe command.



Pipes were made by a series of datum points.



Anyone know how to turn these pipe axes (centerlines) off in the drawing? The drawing looks like crap with them in there.
 

goldlab

New member
Well, it looks like I get to answer my own question again. After some serious banging away at it, it appears my first hunch was correct but I just made the wrong selection.



Solution: 1. make a layer in the drawing. 2. Hit the (+) ADD layer button. 3. pick<Feature> instead of the logical choice of <Axis> 4. toggle the no show eyeball 5. regenerate....



Ta Da!



No, the customise screen has nothing to do with the problem. Customise Screen only pertains to reformatting you icons and mapkeys etc. Thanks anhew.



Goldlab
 

goldlab

New member
Correction. Lost some text...



Solution: 1. make a layer in the drawing. 2. Hit the (+) ADD layer button. 3. pick Feature instead of the logical choice of Axis4. toggle the no show eyeball 5. regenerate....
 
G

Guest

Guest
I'm glad your layers are working for you.



Have you considered the drawing setup file option:



hlr_for_pipe_solid_cl YES



It activates the Hidden Line Removal for Pipe Solid Centerlines for your drawing.
 

goldlab

New member
Thanks for the idea Jason, for some reason the HLR_FOR_PIPE_SOLID_CL YES selection is not working for me.

The only thing that works is the layer no show. (your idea should work but I must have something in my config file conflicting with it)



I will dig around a bit more Selig. Thanks for the help



goldlab
 

FDdesign

New member
The drawing setup file option HLR_FOR_PIPE_SOLID_CL operates only on pipes created in Pro/Piping, not on pipe-features in a part.

So,....the only solution to 'blank' the centerline of a pipe-feature is to put the pipe-feature on a layer.
 

rcamp

New member
< 3. pick Feature instead of the logical choice of Axis>



Technically, these aren't axes. Axes are only straight, these centerlines have curvature.



Glad you found a solution, though. I have to do this for centerline of runners. They are probably the same type of feature.
 

dr_gallup

Moderator
Rather than adding new layers in the drawing, we set drawing layers independantly from the model. We have a standard layer (feat_pipe) that all pipe features are added to automatically during feature creation. Turning this layer off in the drawing turns the pipe centerlines off. We do the same thing for datum curves (layer dtm_curve).
 

vonhofs

New member
Thanks guys, I just came across this and could not remember from years ago how to get rid of the centerlines.


Making a layer took care of the problem and I have asked our admin to change the start parts to include a pipe layer for the future parts.





Scott
 

DHickson

New member
Just wanted to let ya'll know that I was having the same problem & your posts help me out. I used the drawing layers because I tried everything else.


Thanks guy's,


DHickson
 

Sponsor

Top