Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

Starting Pro/E within a Workspace

swcalvert

New member
I'm new to Pro and I was wondering if there was a place to change the location in Intralink for the starting up of Pro/E. The only place I currently know about is in the ilink ptcsetup.bat. I currently use 3.3, but I guess it would be about the same for 3.2, also.



Steve C
 
G

Guest

Guest
Try modifying your shortcut icon for Intralink. In the Properties dialog box, set your Start In: field to the directory that you want Pro/E to start up in.
 

Brian_Adkins

Moderator
If you are going to working with Intralink-controlled files, be very careful not to go behind Intralink's back. Working with files contained in your '.proi' folder without updating your local Intralink database (local.ddb file) is the easiest way to corrupt your workspaces. Yout must use linked sessions of Pro/E wo work with Intralink-controlled data. Even then, never-ever browse directly into your '.proi' folder and work with files... pull them from the workspace.



If you wish to start a Pro/E session that is linked directly to an existing workspace you can use the command-line option (this is from memory, so I could be off a bit):

> proe2001.bat -wworkspacename

This assumes that proe2001.bat is your startup script. Note that there is no space between the -w option and the name of the workspace.



This starts up a linked session of Pro/E that will correctly work with your local database, but the Intralink client will not be running...



Hold on...



I just realized that I may be interpreting your posting incorrectly... If you are asking where, in the Intralink loadpoint, your Pro/E loadpoint location is stored, check <loadpoint>\bin\intralink.bat (assuming you chose the default startup script name). In this file are two references to the Pro/E loadpoint... change the paths here, and that should be all you need.



Then again, I could be wrong on both counts... :)



-Brian
 

swcalvert

New member
Jason, what I'm asking for is a method for changing the start up command and installation directory IN Intralink for Pro/E without going through PTC setup. I have finished (4) Wildfire & iLink 3.3 installs and two of them can launch a session in a workspace and two of them can't. Also, I'm wondering if I leave the 'Installation Directory' & 'Start Command' blank during the initial 3.3 set up, will that cause Pro not to start in a linked session of Ilink?



Steve C
 

Brian_Adkins

Moderator
Steve,



I can't answer definitively for 3.3, but for Intralink 3.1 and earlier, the following works:



<loadpoint>\bin\intralink.bat contains two references to the Pro/E loadpoint... change the paths here, and that should be all you need.



excerpt from INTRALINK.BAT

========================

...cont'd

...

set PROE_START=PROECOMMAND

if %PROE_START% == goto pastps

set PDM_PROE=%PROE_START%

set PDM_PROE_PATH=%PDM_PROE%

:pastps

set PROE_DIR=PROELOADPOINTPATH

set PDM_IMPEX_PATH=%PROE_DIR%\bin\mdimpex.bat

set PDM_MDIMPEX_PATH=%PDM_IMPEX_PATH% -connect apdmpi_dll.dll

...

...cont'd

========================



Replace PROECOMMAND with the name of your Pro/E startup script



Replace PROELOADPOINTPATH with your Pro/E loadpoint directory



-Brian
 

swcalvert

New member
Thanks Brian, I've figured it out for myself. It seems I was trying to type too much information in the 'Start Command' section. It only requires me to direct it to the Pro/E path and it does all the thinking for me. Everything works fine, for now.



Steve C
 

Sponsor

Top