Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

Pro drawings to ACAD creating too many entities

geojoe

New member
It seems that one 90 degree arc in Pro/E is split into 20 or more smaller arcs when I export to DWG. I work on large engine assemblies with hundreds of parts, and the exported drawing files have so many entities AutoCAD crashes. These are NOT complex curves, most are simple circles and arcs, yet they are subdivided when converted. Is there a setting that controls how fine Pro/E subdivides when it exports? Thanks.
 

DrWily55

New member
The problem jeojoe is having is also a problem in WF2.0, build M060 but it does the same thing with .iges files.


I am trying to export a Pro/e drawing to a vendor who uses AutoCad 200?. All curved entities, including 180 (half circles) are broken up into many entities. Exporting in dxf, dwg(or whatever the AutoCad format is)or iges breaks them up into many pieces. You can (in WF2.) specify polylines or splines. Splines works a little better but the half circle is still broken up into many parts, instead of 1 or 2.


Anyone have the same problem? If so, what is the solution? This thread is a year old and the problem still seems to happen.


Maybe someone doesn't want things to convert correctly?


DrWily
 

glanz

New member
In 2001 there is a 12,000 element limit so a large assembly view with
all those polylines can exceed 12k elements and you cannot do anything.
I beleive you can create a group of a view and it then records one
element so you can work on another view. I have large drawings that are
25meg per sheet! In my opinion a 4 sheet drawing hogging 100 meg
is weird these days. On the upside, you do get a correct drawing.
 

DrWily55

New member
Let me explain a little more.


You create a pro/e model(s)and drawing. You do NOT snapshot the views. You then create a .dwg, .dxf, .igs or whatever to be imported into AutoCad. Even if your 3D solids, dtm curves, surfaces were created normal to the screen, and were flat, the imported file gets broken up into many small pieces. This is unacceptable to the people using AutoCAd and trying to use our files.


Most of our outside shops use AC and others that supply them must use the same. They use this geometry and eventually send it to a CAM package to use as toolpaths for machining purposes. Every time it gets converted the lines and arcs get broken up even further.


I have tried all sorts of ways to fix this. Different geometry in pro (curve vs. surface, cosmetic groove vs. curve, solid vs. others, the list goes on and on) doesn't seem to make a difference either.


I just have to believe this problem has happened to some others as well. When the 3D modeling world began to take shape, and others still on 2D AutoCad, this had to have been a problem then. Is there not a solution out there?


DrWily
 

dr_gallup

Moderator
We used to export to DXF all the time to make drawings (pre Pro/Detail), seldom if ever had a problem with the geometry transfer. Circles used to be 2 180 degree arcs but that was corrected years ago. I still occasionally transfer to DXF, generally simple assembly cross sections to do 2D FEA. I do not have this problem.

I just checked an old DXF made with Release 20 and remade it with WF2. Arcs and even full circles are coming through as 1 entity. I do not have any complex geometry in the file. I am importing into AutoCAD 2000 and into MagNet 6, both import the same.

I would try working with a "clean" config.pro, there are so many settings that affect data exchange I think you have some obscure setting messed up.
 

jeff4136

New member
"... try working with a clean config.pro ..."

Good idea. Might also use Find within the Options dialog to look for "dxf". There are a few options like dxf_export_format that might cause this if set to some early Acad version. There's also a section on DXF / DWG export in Interface Help.
 

Sponsor

Top