Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

overlapping surfaces in imported geometry

shaapala

New member
hi all,



can someone specifically tell me the steps involved to heal overlapping geometry? I'm working with an imported feature with the student version of ProE 2001. The online help is incredibly vague and doesn't provide any kind of examples of how the edit boundary menu options are to be used. i am completely open to any and all suggestions or advice.



Thank you immensely,



shaapala
 

mmead0ws

New member
2001:

There isn't a quick answer. Start by redefining the import feature.



1. Always try automatic first. Select Heal Geometry > Automatic > choose the geometry to fix.



2. Next try to zip gaps. Use the default gap distance for the first run. Select Heal Geometry > Manual > Zip Gaps > AutoSelect > Zip Gaps. If it doesn't pick up all gaps, use the Max Gap Dist option to specify a larger value.



3. The remaining gaps will be fun. Review a pair of surfaces that don't match up. Choose your victim according to which one looks malformed. Select Heal Geometry > Manual > Edit Boundary > Choose your surface > Select Contour > choose all or choose the endpoints of the bad edge. Practice with this feature will teach you when to use one or the other of these options.



I would probably delete the bad edge and then replace it with a connect or intersect. When you use the connect, it doesn't necessarily attach it to the existing curves. If Combine is an available option, pick it and connect the new curve to the existing curves before completing the feature.



If one corner of your surface doesn't match up to the corner of the other surfaces you can move that end point with Modify > Move Vertex. Play with all the options here. They all work well for varius circumstances. Once you get a clean edge between the two surfaces, finish the surface modification and try to zip gaps again.



4. Sometimes the surface just won't match up with existing surfaces. In this case, use Exclude Surface to remove the bad surface. Complete the redefine and build a patch surface with Pro/ENGINEER's surfacing capabilities. Then redefine the import feature and merge the Pro/E surface into the import feature with Collapse Geom.



Another option is to use Import Data Doctor (IDD). If it is a small fix, I would follow the steps above. If it is a truely ugly file, use IDD.



In most cases bad surfaces come from IGES files. Pro/ENGINEER can import so many file types now that it is relatively rare to have to resort to IGES. If you can, get a differnt file type, STEP, Neutral File,CATIA V 4.2, ACIS, etc. This list only grows with the release of Pro/E Wildfire.



Hope this helps.
 

peterkobal

New member
I think that you got g good reply from mmead0ws. I would just like to add three things:



1. if you use IDD you should know what surfaces should be frozen (stay the same as imported) and what are going to be tweaked. Check the difference between original imported geometry and the result you get. If it is not good enough reject it.



2. Accuracy of imported geometry affects the result of importing. I suggest you use a config.pro option (intf_in_external_accuracy yes). This will set absolute accuracy of the part to the optimum value. So use this option, then File>Open>(use appropriate file filter )>doubleclick Choose file.



3. Good results are often acheved if you manually sew up two edges manually. I suggest first to use AutoSelect (see point 2 of mmead0ws reply) and then use manual selection of neighboring edges. It is a lot of work. For each pair you have to choose and accept both edges, take an action (ZipGaps) and then confirm or reject the result.



If it is a complex geometry (a lot of rounds) it can take a lot of time to do it, but probably much less than recreating all part.
 

Sponsor

Top