Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

Overiding constraint snap

nofalloff

New member
Is there a way to override the snap to constraints when sketching with out doing it in the intent manager? A hot key perhaps?

When sketching with a lot of entities and references it can get quite maddening to watch you sketch jump all over the place, or get distorted as pro-e tries to snap to things you may not even have the cursor close to.
 

jeff4136

New member
When the constraint "preview" appears; RMB to exclude, <SHIFT+RMB> to accept and use.

Might look at the config option sketcher_rel_accuracy. I'm not sure about this, but think it has a default value of 1. Setting the value higher or lower seems to affect changes in the range of the pick aperature (how far does the solver look for a constraint possible).

Lastly, zooming in so so many possibles are not be calced can help.
 

jeff4136

New member
The mapkey's an easy enough thing to do.

2005-08-21_135232_sketcher_constraints_off.zip

This one is configured to turn off all sketcher constraints and leave the dialog open so you can re-activate some if you want. It could also be set up to toggle all on / all off (manually edit and delete the true / false integer), simply open the dialog, etc.

Set sketcher_rel_accuracy to a small value, i.e. 0.25 to reduce the snap aperature size.

sketcher_point_on_entry seems to preclude point on curve coincident constraints. Allows coincident vertices, RMB to dis-allow as they occur.

sketch_same_point_skamp; don't know what that one does.
 

dr_gallup

Moderator
You may want to try simplifying your model, hide or suppress extraneous features. I also recommend making multiple features with simple, robust sketches over making one complex feature with lots of section elements.
 

Sponsor

Top