Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

importing a part & getting wireframe

rullan

New member
In ProE 2001, I'm trying to import a part to use in an assembly and/or a drawing. The part is viewable as a shaded part only, all other view types are wireframed with a pink color.



This is no good in a drawing because the part (and the pink color) overwhelms anything else in the drawing.



Is there anything I can do to the part to allow other views

(i.e. hidden line, hidden line in grey, etc.)?
 
G

Guest

Guest
This is because the model you are importing is made up entirely of surfaces. Magenta (pink) color specifies internal or 2-sided edges. Yellow specifies external or 1-sided edges. If you see nothing but magenta, then you can turn your model into a solid by Insert > Protrusion > Use Quilt.



For drawings, you can use the config.pro option:



hlr_for_quilts YES



This removes hidden lines from your drawing views. Surfaces will still show up as pink an yellow in your drawing, but when you plot your drawing, it will look normal. At least this config.pro option cleans up hidden surfaces in your drawing.
 

rullan

New member
Thanks Jason for your input. I don't have any experience with quilts, so I couldn't figure out what to do once I got to Insert > Protrusion > Use Quilt.



But it did look like I was on to something.



As far as changing the file hlr_for_quilts (yes), I didn't see any difference in the drawing. I still saw a dominance of magenta even when I plotted. But maybe that's due to the model not being repaired.
 
G

Guest

Guest
If all of your surfaces are closed and merged, then you should be able to turn your model into a solid. It may require some healing of some imported surfaces. Without seeing what you have, it's hard to know if this is possible in your case.



If you plot your drawing in black and white, it should look ok. If you're still seeing hidden lines after you set the config.pro setting, set your Modify View > View Disp mode to No Hidden Lines. Regenerate the views with View > Update > ...
 

Sponsor

Top