Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

importing 3d models

rullan

New member
version 2001


Sometimes I need to importa 3D model from a manufacturer in order to workitinto my assembly. Most of the time the part has pink or yellow edges, and if I need to modify it, I can only create protrusions (no cuts).


I'vealso noticedin my drawing of the assembly, that same part has pink or yellow highlighted edges and I cannot find a way to modify the colors to match the rest of the drawing. The drawingtakes a long time to repaint as well.


Is there anything I can do either in the modeling stage or the drawing stage to resolve these issues?
 

wsylvester

New member
Rullan,


Do a search on importing and you'll find what you need to do. It's not a solid


yet. Hence the yellow lines and no ability to make a cut
 

nmvselvam

New member
The imported part is not a soild thats why it is pink in colour .The surfacepart not cuted using cut option You should convert these surface to solid using protrusion< use qulit option (before trying you should convert closed surface of the imported part)
 

Heathbn

New member
Rullan


The parts are coming in as incomplete surface envelopes instead of a solid model.


Their are a few things you can do to get them to come in right.


1. instead of opening the import file open a new part. change the accuraacy from .0012 to .0002. then import the file into this part.Most of the time this will fix the problem but sometimes it makes things worse.


2. If for whatever reason you can not get the file to come in as solid then you can still cut it by using the trim surface feature.


If you are going to be importing files into pro-e reagularly I would recomeand taking a surfacing class with Bart from http://www.proetools.com/


I would recommend that you always get it turned into a solid before you make a drawing of it. this will eliminate your colors problem.
 

Moroso

New member
Pink are the surfaces of the part and the yellow edges are the edges of a particular surface that did not mesh.


Those are the areas you concentrate on when you try to manually fix the imported geometry after you've tried the automatic method
 

Mattlindsay

New member
Just to clarify,


in 2001, you do not have the "solidify" option, it is slightly more old school, you use feature>create>protrusion>use quilt.


If however, like you say you have "yellow edges", this is where surfaces break out into the open and will indicate holes. If you imported the geometry, in the model tree you will only have "Import Feature id (#)". If you right click on this and hit redefine, it should give you the option of "Heal Geometry". (You may need the pro/surface option for this). If you use that, hit


Automatic>Include>all surfaces>done


then it will compute its ability to heal. Hit compute in the next box and then accept and it will do its best to fix up your surfaces. If this still leaves yellow edges then you can fiddle them with the "zip gaps" option (this gets a little more involved).





It's 100% worth it to try and make your model one solid if you are taking drawings from it, I have to do this all the time and the time is worth it in the end.





Try and get a better export from your clients, or give STEP a bash.


Best of luck





Matt
 

emiliew

New member
i'm having the exact same problem.. i'm using wildfire 2.0, and have a single importedsurfacethat is basically like one big jello-mold (no holes in the surface)


the problem is that theback is open, thus, the pink edges.. but i can not cut or protrude or do anything worthwhile to close the back of this model! i've imported andexportedit as various things, but still i can not perform any merges with other surfaces, orsolidifies, or anything.. <?:namespace prefix = o ns = "urn:schemas-microsoft-com:eek:ffice:eek:ffice" />


am i missing something? how else can i close this model so i can prototype it ?!
 

Brian_Adkins

Moderator
>>I'vealso noticedin my drawing of the assembly, that same part has pink or yellow highlighted edges and I cannot find a way to modify the colors to match the rest of the drawing


To make surface act like solids (i.e. hidden line views) on drawings, Use the view option "Hidden LIne Removel for Quilts" in WF2. If you're using 2001, look for the option titled "Quilt HLR" or something like that...


-Brian
 

Mattlindsay

New member
Yeah, best thing is if you can post the file (if you have permission to). Would be great if once it is fixed, the process can be explained to help all.


The other option of course is to use the quilt and thicken it if it is a mold or similar to make a protrusion? As with most surfacing stuff it depends on the model. Post it f you can, or a similar example.





Matt
 

rasesh

New member
whenever you have an imported geometry you have to use the import data doctor functionality of pro/engineer wildfire 2.0.after importing the file it will appear as imported feature in the model tree(import feature id###).now rigt click on import feature and then edit<definition.now a new menu will appear on the menu bar titled geometry.click on geometry.in the pull down menu click on heal geometry<manual.now a new set of options will appear.click on zip gaps<autoselect.now pro/e will patch up all the open surfaces and make a closed quilt of the import geometry.in the selection filter select quilts.on the screen select the entire closed quilt and then edit<solidify.the quilt will get converted into a solid feature which can be then used in further downstream applications whwther be it design,analysis or manufacturing.
 

BugStar

New member
Hi,

Another related query.

I'm trying to import a .STEP file of an assembly from one of our suppliers into a WF2 assembly, I've tried all of the methods that I can find in the help files, but the files never even appear in the navigation window.

Is there a config option that I'm missing somewhere or something stupid like that?
 

Sponsor

Top