Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

How can I set up proe units in mmns?

I have read what dougr asked and I changed at utilities-options- pro_unit_length unit and pro_unit_mass unit in mm and gram respectively. Also, I changed from utilities-options the template_designasm, template_solidpart and template_sheetmetalpart in mmns. However all these changes occur only in the current session. If I close proe and then open it again the units arestill in inlbs.
 

Speling

New member
When you start making new part, do not use default template. After that step, choose mmns_part_solid and that
 
The thing is that if you open a drawing file there isn't a default template option to change it. So even if you created a part in mmns by the way speling said..its drawing file will be in inlbs... I know, that because if you save the proe darwing file as dxf and then open it in AutoCAd.. you need to scale it in order to have the same dims. Also if you try to do the opposite thing..to open a dxf file from AutoCAD as a part in proe... again there isn't an option to change the default template. Therefore, i need to know how can I change the settings so that I can always work in mmns.
 

Speling

New member
pro_unit_length UNIT_MM

pro_unit_mass UNIT_GRAM



That is all I have connected to configuration commands in my config.pro and with way of work described above I get all I want
 

dr_gallup

Moderator
The problem is if you create a new part that is a copy of a start part (or asm), you will get the units in the start part. So you have to open your start part (or asm) and change the units there and save it. If you use those stupid inlbs start parts you are screwed because those are built in and you can't change them. To make them go away I had to set the following config.pro options:



start_model_dir (old)

template_solidpart (new at 2001)

template_designasm (new at 2001)
 

it123

New member
i use wildfire 2.0 and i did the following:



pro_unit_length unit_mm

pro_unit_sys mmns

template_designasm C:\Program Files\Eng\proeWildfire 2.0\templates\design_asm_mmns.asm

template_solidpart C:\Program Files\Eng\proeWildfire 2.0\templates\mmns_part_solid.prt



but when i close and open pro/e, the template is again inlbs



I could save the mmns.prt files as inlbs.prt files but that is not correct



Does anybody know how to do this?
 

it123

New member
I think i was blinded by rage
, thats why i couldnt find it...



I modified a config.pro file that was in jlink ( a sub directory of text) as i thought that was the config.pro file used




It works fine now,



Do you where can i find some commonly used options for Wildfire 2?



Thaks Israr
 

dudelman

New member
Israr said:
it123,


Learn how to make and where to save config.pro file.


Israr
Is your answer supposed to be helpful or what? Why, while already going through the trouble and responding to it123, don't you just tell how to do it? Others might be interested, too.

- dudelman
 

Sponsor

Top