Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

GTol’s in assembly

phoxeoy

New member
I have a very old drawing that just has an assembly drawing with two
parts. Both parts are dimensioned from this one assembly drawing. The
problem that I have is they have a Datum A on one part and a Gtol
referencing that Datum and is attched to the other parts outter
diameter dimension. Well, Pro wont let you do this so, What the hell do
I do?



Does the makers of Pro/E know that sometime assmeblies get some machining done to them after assembly?
 

dr_gallup

Moderator
Pro/E is very restrictive about what it will let you attach GTOLs to and what datums you can reference. It drives me nuts. First try all the options as far as what model you are using for the GTOL reference, try using "drawing". Second, try creating an additional datum A in the assembly but don't display it. I know that is bad practice but it works. Third, fake your GTOL with a note. Use the @[[email protected]]@[[email protected]]@[[email protected]] format to but a box around it. This is even worse practice. Forth, take a large hammer to your computer.
Edited by: dr_gallup
 

phoxeoy

New member
I ended up just putting the datum and Gtol in with the model. Although the Datum is apart of the other model but I can't fake the Gtol because of two reasons


1. We have other software that translate features and tolerances so if I fake it the Gtol will not show up.


2. We go though a company that checks all are models and drawing and they would red flag it.


I run into issues like this all the time and most of them are because of Pro/E and the lack there of. We have to make the model 100% assiocative but Pro/E does not make it easy in some areas. It's a headache!
 

cmiwb

New member
Something to try, in case you don't already have it, is to add to your config.pro "Create drw dims only" with a value of "no". This solved some drafting gtol issues we had but I'm not sure ifyour problem was one of them.
 

Sponsor

Top