Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

Exporting surface colors

victor-dot-com

New member
Hello,

To make things easier for our tooling vendor, we shade surfaces different colors to show which areas are textured. This works fine when the parts are simple and I can just shoot screen shots. But we have some really complex models that I need to export 3D files to them. My question is, how can I export 3D data that will carry over the surface colors? FYI, we typically use STEP files for export, but we can try something else.

Or, if you have another suggestion for relaying the information, I'm open.

Thanks,

Victor
 

canoemike

New member
Check your config.pro settings, there is a setting for this. I do not have access to my work config.pro now but I will try to check back on Monday with the setting.
 

victor-dot-com

New member
Thanks for the response Mike. I came across that setting, it's setting the "STEP export format" to Ap214_is. But when I tried importing that STEP file, it did not carry the surface data. I'm beginning to wonder if Creo's import engine is screwing it up. I'll be sending out files to our vendor today, will report back if the above setting worked.

Thanks,

Victor
 

canoemike

New member
Victor,

Glad to hear that you found it.

below is some info related to your original question.

What is the difference between .STEP file formats AP203 and AP214?

Generally, AP203 is a "general" STEP format.


AP203 defines the geometry, topology, and configuration management data of solid models for mechanical parts and assemblies. This file type does not manage Colors and Layers.

AP214 has everything a AP203 file includes, but adds colors, layers, geometric dimensioning and tolerance, and design intent. AP214 is considered an extension of AP203.

As for the surfaces not showing up, did you check the layers to see if they where hidden ?

Funny thing with one question they always seem to lead to another. All the Best !
 
Last edited:

victor-dot-com

New member
Thanks Mike for the additional info.

I was able to confirm that the setting worked. The reason it didn't work before was really odd, and I really can't explain it, easily. LOL! I'll attribute it to typical PTC gremlins.

Thanks again.

Victor
 

Sponsor

Sponsor

X
Top