Continue to Site

Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Dimensions that are piled on top of each other in Sketcher


When applying and modifying dimensions in Sketcher, I'm noticing how the Strong dimensions don't stay put afer a regen. This is very frustrating. Sometimes many of the dimensions will pile up on top of each other making for extra work visualizing the sketch. Am I doing something wrong with my technique? Or is there a way to lock the dimensions down so they will stay where you leave them, even after a regen?

Thanks in advance,


I remind you that the system dimensions are called weak dimensions (they appear in gray), because the system can remove or change them without your input.

If you have for example a rectangle and you enter a value for the sides of the rectangle, the system after you do that convert these dimensions to strong. When you dimension the side of the rectangle you pick the two side points or the whole side. When you select the whole side the system looks for the two ends of the line and create the dimension. Lets try to create a round on the corner of the line (that we had dimension before). We can see that Sketcher deletes the strong dimension because the original references are lost. The two points that we have picked to create the dimension are not exist.

This an example of a case that the system deletes your strong dimension.

I believe that the Sketcher in proe is strong enough (except importing data from another *.drw or *.dwg file) and if you select the right references for your strong dimensions you want come up with any problem.

According to the lock option let me remind you some topics from PTC on line help :

When you use Move from the Edit menu without locking dimensions, Sketcher determines which dimensions to lock and which to vary. You can tell Sketcher specifically which dimensions to lock by using the Lock command in the Edit menu. Notice that as you pick a dimension to lock, the letter L is added in front of the dimension value.

You may also lock all dimensions with the Toggle Lock command and then click Edit > Toggle Lock to selectively unlock dimensions that you allow to change during dragging. Notice that when you select a locked dimension and click Edit > Lock, it becomes unlocked and the letter L is removed from the dimension value.

When you lock all dimensions in Sketcher mode, you cannot change the section

Thanks for all your help, I set my to not automatically refit after changing dimensions in Sketcher. This works very nicely! Also the dimensions seem to be staying where I put them. I don't know why but this setting seems to help!

Would you be so kind as to mail me your and files? I would greatly appreciate it! I'm learning Pro/E on my own time, and I'm finding a lot of information on this site that is not in the books I'm studying! The settings in could be an entire book just on their own!

Thanks for all of the tips. I really appreciate the help,


[email protected]


Articles From 3DCAD World