Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

2001 SE Slow movement with 2 parts open

boydt

New member
I have a Dell D600 Laptop Pentium M 1.6, 512 ram, ATI Radeon 9000 w/ 32 MB. Modeling/assembling parts works great and is fast untill I open more than one part. When this happens, everything becomes dreadfully slow. Anybody know why this is happening and/or how to fix it?
 

skuld

New member
Hi there boydt:



This problem is indicative of your graphics card's unified back buffer being switched of in the Graphics card's driver settings. What graphics card does the Laptop have? If you're not sure you might try using win32_gdi instead of your Open GL graphics driver.



This problem is just not a Proe problem but will happen with any CAD software when you try and run it on a domestic OpenGL Graphics Card.



For a detailed description of the problem and a possible solution go to http://www.solidworks.com/pages/services/HardwareSupport.html?PID=255#L4



And look for the
 

boydt

New member
Thanks skuld, your solution half worked. Now the first part I have open will move smoothly, but the second, third, etc part/parts are still choppy. Any other ideas?
 

skuld

New member
Boydt...



What graphics card is fitted to the Lap top and what version of the drivers are you using? Also how much video ram is fitted to the graphics card?



Skuld.
 

leo

New member
If you go to view >performance change your level of detail

It helps to rotate parts with a high level of detail.
 

boydt

New member
The graphics card I have is an ATI Mobility Radeon 9000 with 32 MB RAM on the video card - and I just downloaded the latest driver:

Version : A02

OEM Ver : 7.80.4.1-030103a-7165c



Rotating parts with a high level of detail and complex curves is not slow - it is just after rotating that the program pauses for a few seconds to redraw the screen (just when more than 1 part is open) - which is really anoying.
 

Nose Bleed

New member
Boydt - How many other applications do you have running in your tool bar? You might want to disable some if you have a bunch - It might not be your graphics card - You've got a pretty good computer it sounds. I'm running a 4MB graph card on a 300 MHz - Never had that problem....



Many applications run in the background, and may be using up processing speed...
 

Heathbn

New member
I have a Sony laptop with mobility radeon 7500 32 mb ram.

I own a seat of the flex 3c on it.

OpenGL works great for the first window but I do have problems with it when I go out of sketch. Some times it just slows way down. I find if I go back into sketcher and out again it clears the problem.

The most resent thing that I did to help was turn off the config pro setting call overlays_enabled. You will find it under category system set it to know this should help a lot.



Both of use have cards that work just fine on a desktop but know one has bothered to tweak the driver in for the mobility version. Hopefully some one will do this soon.



Something else I found is that wildfire has no graphics problems at all on the same computer how about that.
 

skuld

New member
As I said in my earlier post, most of these problems are to do with the unified back buffer on the graphics card. Unfortunately on most domestic OpenGL cards this function is fixed and cannot be switched on or off. Normally in domestic OpenGL applications (mostly games), you would only have one full screen window running OpenGL. This is why the window runs OK but if you open up a second OpenGL window, due to the addressing of the back buffer, thing start to slow down.

On older the NVIDIA drivers this function was switchable but NVIDIA found that people were using High end domestic OpenGL cards for professional CAD / DCC applications, and this impacted on the sales of there High end Professional Cards (aka Quadro based chipsets).



The only real solution is to ditch the domestic cards and go for the professional cards. Look for the Quadro4 or Quadro FX from NVIDIA, The Fire GL from ATI or the 3Dlabs professional cards. Here at work we only use the Quadro based cards and have found them to be very consistent with all our applications. We have Solidworks and Unigraphics as well as ProE plus various specialist FEA applications.



I see that some of you guys are running laptops and changing a card in a lap top is not quite as easy to do, so you may just have to keep the number of windows open to a minimum until you can justify a new Laptop.



Regards Skuld
 

Sponsor

Top