Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

Tip for importing sketch data from a file

bhayden

New member
I've found that importing data from a file (.dwg format) the geometry often gets mangled. I'd like to offer this tip/work around. After you select and open the .dwg file the geometry appears floating somewhere on your screen and you are given a dialog box to pick scale and rotation. Like when sketching, the geometry is usually super sized. I haven't clue why the default scale isn't set 1:1 but anyway if you just accept the default the geometry comes in much cleaner.



I thought this might be because of the way the Intent Manager dimensions the entities. Again, I can't think of any good reason but if you turn off intent manage then the option to import geometry from a file is greyed out. The interesting thing is that if you accept the default constraints (I made them strong dimensions) and then do Modify > Lock Scale the geometry scales correctly.



Looks like a bug, walks like a bug, must be a bug. BTW, I tried the same thing in Wallflower and got the same result. They may have changed the mouse interface but at least they left it bug compatable :+)



Bernie Hayden

XKL LLC
 

mvitez

New member
Thanks, it helps. I didn't know that. I always made the scale 1 and had problems with constraints. :)



mvitez
 

Sponsor

Top