Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

Setting a new text editor

Lucid3D

New member
I am editing standard notes and tables. Iwanted to utilize spell check and other features in word that the standard editor does not have. This is to alleviate the use of model check.
 

wsylvester

New member
I didn't think it would work.. but just tried it and it does


in config.pro;


pro_editor_command C:\office\Office\WINWORD.EXE


drawing_file_editor editor


path will be where ever your Winword.exe lives
 

Lucid3D

New member
I tried that already. have you tried to open the editor from the properties of a note? ms word opensbut fails to bring up the file, and I receive an error.
 

wsylvester

New member
Don't know what to tell you then as it works on my end .... i create a note.. then select it.. get properties.. then textbox comes up... I click the editor command button..


Word come up with the text from the note in it... i edit the note.. add some more text..etc .. save and it is now in the drawing


Word is in it's temp file mode... if I click on the save as.. to see where it is running then it show me


C:\Documents and Settings\My user name\Local Settings\Temp... ithas a number for the file name.. it is the same way excel is working when I use it to create family tables


I am on r2001 proe and office 2000...non networked everything is on my machine
 

Lucid3D

New member
We are doing the same thing other than I am running proe wildfire 2.0 m120 and office 2002and we have . thx for the help anyway I will see what i can do, itsounds like it might be a software conflict.
 

wsylvester

New member
there may be a additional option in WF ... I double check and when Word comes up I have a vba macro in my doc temp.. it just a liitle one.. if you have any heavy-duty macros in your Word template you might want to save them out and try with a bare bones setup


but the 2 config options seem to do the trick with r2001...only other one I could think that could have some effect is the new option in WF to set to working dir....I don't remember what the exact syntax was but it was just in a thread... I'll bail out send this and grab it... you may already have it set tho
 

wsylvester

New member
file_open_default_folderworking_directory


if you have that set already... well I guess that isn't it... if not add it in and that just might do it.. .. it's default in r2001 ...not even an option...but wf ?? it's new


why it would need it..who knows asWordis running in that temp folder off ...C:\Documents and Settings\My user name\Local Settings\Temp
 

Lucid3D

New member
I checked file_open_default_folder and it was set to working directory. I tried in session andmy documents and it didn't work either. According to the error it states that it could be permission issues. there error is below:View attachment 1118
 

wsylvester

New member
yeah Billy,


That's looking like a Word issue...but you're close


For what it's worth .. I looked on my general options in Word.. only thing that sort of ties in with the warning you get is


Confirm conversion at open.. which I don't have checked.. just a thought.. couse if you don't have it check either .. then it's ruled out
 

straupma

New member
I was getting the same error....but then I found that since I had Word open that was the problem. Try making sure Word is closed and then it should work. I'm using WF2 and Windows 2000.
 

Lucid3D

New member
that was it! I use word as my default email editor in outlook, and I always have it open. I closed down outlook and it is working. thanks
 

Sponsor

Top