Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

Scaling Oddities

joeljkp

New member
I'm attempting to build a wing using a parallel blend. Here's the steps

I go through to create my part:



(Pro/E 2001)



1. Create datum points from external file (airfoil)

2. Create datum curve through points

3. Start parallel blend

4. Place entity on datum curve

5. For other wingtip (other end of blend), place entity on same datum curve

6. Scale second entity to desired size

7. Specify blend depth

8. Finish



My problem is with 6, the scaling. The width of the wing (from leading

edge to trailing edge) is 1.0. When I give a scaling factor of 0.55 for

the second entity, it performs as expected and scales to 0.55 of the

first, and then I can specify the depth and I have a tapered wing

section. When I give a scaling factor of 0.56, however, the entity

doesn't scale at all, it just seems to move. What's going on here?



If you'd like the part files (or trail files), I'll provide them to you.



Thanks in advance.
 

bhayden

New member
Not sure if this will help but I've seen similar behavior trying to specify thickness of sheetmetal parts. The answer was to change the accuracy . I think the config.pro option is accuracy_lower_bound. But I've changed it from the Menu Manager:

#part

#set up

#accuracy

Try setting this to a lower value.



Good luck!



Bernie Hayden

XKL LLC
 
G

Guest

Guest
bhayden is right, I believe. I think it can be accomplished without the config.pro setting though. The default value is .0012. Work you way down from there. Try .0010, .0008, .0006, etc. The smaller the value, the more accurate Pro/E is in it's calculations. Pro/E will recognize smaller line segments.
 

joeljkp

New member
I tried an accuracy_lower_bound setting of 1E-6, to no avail. The problem isn't with smaller line segments, it's with larger line segments. Pretend this rectangle is a wingtip:



----------

| |

| |

| |

----------



I need to scale the other wingtip in relation to this one:



----------

| ----- |

| | | |

| ----- |

----------



(looking at the wing from the small wingtip to the large [root] wingtip)



If the smaller one in the above picture is scaled to 0.55 of the large one, everything is fine. If I scale it to 0.56, or anything larger, the following happens:



--------------

| | | |

|(1) | (1) (1) | |

| | (2) (2) | (2) |

--------------



The scaled wingtip (1) doesn't scale at all, it just moves in relation to the original (2).
 
G

Guest

Guest
Just setting the config.pro option will not do it by itself. Did you try Setup > Accuracy?
 

bhayden

New member
Sorry if I've lead you down the wrong path. Now that I think about it some more I believe you would have gotten an error message of the sort scale value must be in the range #.## - #.## if the accuracy was the issue.



Are you sure that the geometry you are asking it to create doesn't have some quirk that makes the larger scaling impossible?



Another shot in the dark. Try turning off intent manager. It can sometimes reach a ratio that makes it decide things should be aligned when you don't want them to be. I run into this a lot when I import .DWG format geometry into sketcher and holes fall near a centerline or datum. The bigger the base part the more intent manager insists on mangling the imported geometry.



Bernie Hayden

XKL LLC
 

joeljkp

New member
Maybe this would be of help:



Part file for 0.55-scaled version: http://www.ballsome.com/scaled-55.prt

Part file for 0.56-scaled version: http://www.ballsome.com/scaled-56.prt

Trail file ending at scaling step: http://www.ballsome.com/scaled.txt

Points file (needed for trail): http://www.ballsome.com/naca0012-34.pts

Config.pro: http://www.ballsome.com/config.pro



I tried the intent manager thing, and I couldn't figure out how to work it. It seems that the scale/rotate option goes away when I turn off intent manager.



This is Pro/E 2001.
 
G

Guest

Guest
I looked at your file and I could not get it to work right. I got the same results you speak of. I tried changing accuracy, but to no avail. Perhaps PTC should take a look at this one.



However, I was able to make your airfoil with a swept blend. I pulled in another point file at a scale of .56 of the original and used a swept blend to bring the two ends together. There may even be an easier way of saving the sketch then pulling it in as a sketched curve at a scale of .56, then doing the swept blend, but I didn't try it. Anyway, you can see the scaled .56 airfoil that I made at:



http://www.proecentral.com/uploads/files/scaled-56-sweptblend.prt.zip
 

Sponsor

Top