Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

Modal analysis problem

GeorgeTsonev

New member
Hello everyone I have a strange problem.
I decide to make a design study- modal analysis and I want to find all frequencies in this range 50
 

Mechwitch

New member
George,


I have had the exact same problem today and I'm just off the phone from the PTC helpline.


The problem seems to lie in the operating system - I'm running with windows XP - which will (apparently) only allow 1.6 GB of memory to be used for the application, so even if you had 10 GB memory you would still only be able to use 1.6!!


The only other suggestion I had was reduce the figure in the memory allocation (minimum is 24) but it will take a lot longer to run.


Failing that we're back to cutting out all unecessary features again..........


If anyone has any other ideas how to improve this please share
 

Luis Aguirre

New member
George,


Why not using single pass adaptive instead? SPA will use by far less memory and will get you close to the answer. There are multiple ways to improve SPA if your shooting for accuracy. For example you may want to run the model then post process the solution and look at the P-level. The location were you get the highest P-level you may want to increase the mesh desity and run the model again. Doing this should improve the accuaracy of the results and used less memory that by runing MPA.





Luis
 

GeorgeTsonev

New member
Hello
<?:namespace prefix = o ns = "urn:schemas-microsoft-com:eek:ffice:eek:ffice" />
Does anybody know how can I filter the results of modal analysis and the computer to save only the peaks of the frequency spectrum or how can I correct the accuracy and change the steps of the frequency results? For example, when I do a modal analysis and from the Frequency Option/ Number of Frequency menu I choose 10 around 100Hz, I receive this modes 100.01; 100.02; 100.04 and so on. What should I do to increase the steps between the modes?
 

mch

New member
George,


The thing that strikes me is that your memory allocation is way too high. I've had sucess in modal analysis when I've reduced the amount. In any case there's not much benefit in allocating more than 512Mb for windows machines. The other thing is that you are using the iterative solver. This solver is very slow in comparison to the block solver which is why it is the default. If you do use the iterative solver you shouldn't allocate more than 64Mb to it.


Another thing to consider is how many modes you are requesting. If you have a large number (in excess of 100), then you can run out of memory just writing the results. If this is the case it may be better to use the quick-check or single-pass solver.


Rod
 

Luis Aguirre

New member
George,


It seems that your model has some sort ofsymmetry. When the model have symmetry the eigensolver will give you modes that are very close to each other. This means that any of those modes could be excited depending in the direction of the load. The only way to reduce the reapeated modes is by braking the symmetry.


Luis
 

Sponsor

Top