Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

license borrowing

jesterphat

New member
ok WF 2.0 m040 date code



laptop hooked to network... run the borrow batch file

succesfully borrow license. Do a ptcstatus...properly shows carrot symbol adn license looks to be checked out.



unplug my network cable to laptop, restart proe (making sure it matched...foundation checkedout) and it fails to see a flexlm licensing feature... do a ptcstatus on my unconnected laptop and there in white letters on a black screen it shows that i has a license for me.



what gives... have tried several things and even running ptcsetup to try to add a new location...with no luck. It seems to want a flexlm license when the borrowed license wont have one...



what i can do is hook up network cable... gets the dedicated checked out license start up proe and it works... unplug network cable...and it still works..create files, change directories..works without a network cable as long as i start up the laptop connected



looked thru the ptcuser adn here through the forums... hasnt anyone utilized the license borrowing?



or those of you who are succesful...can you give me a little insite?
 

Heathbn

New member
you are using XP right? Its the networkcard not PRO that is the problem. You need to turn off media sensing if you are using XP. you see when you unplug form the network your laptop can not see the network card or the host id.
 

jesterphat

New member
yes XP



ok i did disable the media sensing... no luck



Fatal Licensing error: No valid license servers available



Warning: Ethernet Adapter was not detected



ok so i have tried a few other things off and on...



I did install flexlm after the fact... now i have the license until midnight tonight... so maybe thats a quirk... must have the flexlm before i borrow.



also looking at the flexlm notes that it requires a borrow naming convention within the license identifier?



anymore help???



should the nic card be picking up on me installing adn uninstalling the net cable? I thought by me going in and and changing my registry that should have stoppped?



a nondigital worker in a digital life



thanks for all your help
 

narok

New member
I had the same problem with the Flexlm and the proble i had was that when it was pluged in the network it would work fine you unplug it and it wouldnt. THe main key to it was to disable media senseing. (i have an email from ptc on this if you would like me to forward it on how to disable media senseing) but then i figured out that when it was unpluged from the wired network cable proe was looking at the mac address for the wireless card so i just went to the network connections and diabled all the network cards except the wired 10/100 card and it would work fine. (or you can get another lic file to register off the mac address of the wireless card also).

So maybe that might help
 

narok

New member
You can also pull up a command prompt and type ipconfig and or ipconfig /all and if the address comes back 127.0.0.1 or any 127 address then you do not have media senseing diable properly. I also had to run ptc setup and pick the flexlm lic to get it to work as well.
 

jesterphat

New member
great stuff Narok... thanks i appreciate it.



I like the config info .. helpfull



I did get an answer from PTC and another gentlemen from the navy.. my problem was the M040 build... doesnt support license borrowing, neither does the 030 build..



I downgraded to 020 build and all works well!



is a thing of beauty when it finally works... of course thats why i bought my new Alienware Roswell Mobile computer... for this specific reason!
 

narok

New member
Here is the info on media sensing i have recived from ptc just as an added bonus... or whatever you want to call it

Ill have to post them in two seperate post because of the limitations of the form



Two things interfere with detecting the host ID on a laptop;



Firstly, in the Windows registry the listing for the docking stations

card may be listed before that of the onboard card. Simply renamed the

numbered folders containing these cards will allow our script to see

the onboard card first. This fixes this issue most often. This fixes

is in the registry so if you are not comfortable or familiar with

making changes there I strongly recommend contacting your local IT

support for assistance and backing up the registry before proceeding.



In the key



HKEY_Local_Machine\Software\Microsoft\WinNT\CurrentVersion\NetworkCard

s you will see a few folders with arbitrary numbers, listed in

alphabetical order. Opening each folder and checking the Description

line will show you which if them matches the make and model of your

onboard card. You then right click on the folder and select Rename,

renaming this folder to the number '1'. If there already was a '1' you

will have to rename that first to some other number. Close Regedit and

reboot the machine. The correct hostID should come up thereafter.



Secondly, a Windows feature called Media Sensing might be turned on.

What it does is detects whether network adapters are in use -getting a

signal, and which are not and prioritizing them by this. The idea is

that when you stop using the onboard card, it sort of shuts off, when

you turn on the Wireless card, it is seen and enabled. I recommend

disabling this feature. What, if any, impact disabling this feature

will have on your Windows environment I cannot say but I have heard of

no impact as yet. See the Below TPI.





When a Laptop, or PC, computer running Windows 2000 is physically

disconnected from the network the IP address is changed to 127.0.0.1

regardless of the Static IP address specified in the Network Settings.

TPI 105508
 

narok

New member
And here is the second one...



Description

-----------------

Windows 2000 contains the Media Sensing feature to detect whether or not the network media is in a Linked state. A linked state occurs when the physical media is connected to the network. If Windows 2000 detects a down state on the network media it removes the bound protocols from the adapter until it detects a Linked state. As a result the IP address defaults to the loop back address 127.0.0.1 which may cause errors with Pro/ENGINEER and FLEXlm.



Alternate Technique

-----------------

See Resolution below



Resolution

-----------------

1) Reconnect the network connection then reboot the computer. This

will restore the orginal static IP address.



Or



2) Go into the Registry by selecting the Windows 2000 Start button,

Run, type regedit, then select OK. Browse to

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters.

Double click the Parameters folder then right click on the right side of the Registry Editor window and select New, DWORD Value and change the new value name to DisableDHCPMediaSense. Right click on the new entry and select Modify and set the Value to 1 to disable the Media Sensing feature.

Reboot the computer. This will maintain the bound protocols when the computer is disconnected from the network.



Thanks,

Jason Miller

narok
 

rcamp

New member
Jes, Are you saying this enables you to run ProE without being continuously connected to a networked license?



That is cool.



What's the advantage of the Alien portable over any other?
 

jesterphat

New member
alienware... one of the few computers (that i know of...and i dont know much)..mobile that is that has the Nvidia FX ultra go1000 video card... a certified card by proe...

and i am a huge gamer... its dream machine for me...hehehe...



I am completely surrounded by Dell...nothing bad... but Dell, Dell, Dell ,Dell and more Dell



you can look at it here



http://www.tcpug.org/alienware



its a geek thing :)

3.2 p4 512 cache 800 fsbus

60 gig harddrive

Nvidia FX Ultra Go1000

DVD+-RW

wlan abg built in

gig nic card

and a bunch of other built in features
 

saymo

New member
am i right in reading that the license borrowing worked in m20,

but not on future datecodes, ie m30 and m40??

I thought the reason for datecodes were to fix bugs....not create them...??



so if you want license borrowing, youve got to downgrade and take on all the bugs that were meant to be fixed previously in earlier datecodes??? even if they hindered your work before



If this is true , this is total madness.....



with the timeout issue



being told that WF is backward compatible,,,its not....not in native proe extensions



then WF crashing at will....



now this nonsense



whats next !!!
 

Sponsor

Top