Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Layer status inconsistency in drawing views

mdemers

Member
Hi,
A colleague and I have been running into an issue for a few years now and I couldn't find any trace of that issue in existing forums posts. So here it is :
We sometimes create, in parts, 2D sketches that do not lead to 3D features. These sketches are meant to represent important elements in the eventual drawing, but not in every drawing view. The method for getting this done is simple :
1) In the 3D part, make sure the sketch is on a layer.
2) In the 2D drawing; go to the layer tree; select the layer containing the sketch; right-click and hide
3) Still in the layer tree, click the arrow in the top-left corner; select the sole view in which I want the sketch to be displayed. That view's layer status gets reset.
4) Still in the layer tree, select any layer; right-click and save status.
5) Save drawing.
I must have been using that procedure for, like, 20 years. What I've started to experiment only a few years ago though is that if I close the drawing, erase not displayed, and reopen the drawing, the layer status is mixed up. Most of the time, the sketch will show up in every view, although I can see that the layer status is ok (i.e. hidden for "top model"). And if I print the drawing or issue a pdf, layer status is fine. So it's really just on my screen, and that of colleagues of mine.
Is it something you guys have been experiencing? Usually, when a problem like that is witnessed at the screen but does not follow through printing, it is related to the graphics card, right? Or is there some surprising config.pro option that causes that behavior?
Thanks,
Mathieu
 

Sponsor

Top