Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

Import Parasolid (*x_t) in Proe/Wildfire

keyurkanade2

New member
Hi,



I got (*x_t) files from client. I want to open it in Proe/Wildfire. But
while opening, it gives message 'No files or directories found.' I am
stuck here only. I can not do further operations.



Does it require some licence to import Parasolid file in ProE?



If anybody knows it, please tell me so that I can proceed.



Thanks,



Keyur
 

xcad

Member
send us the parasolid info


direct from PTC:


Pro/ENGINEER Wildfire builds 2002490 through M160 can import parasolid versions 3 through 13. Build M170 and up add support for Parasolid versions 14 and 15.
 

keyurkanade2

New member
Hi,



Because of some reasons I could not reply this mail. Sorry about that.



I did not understand the meaning of nombers 2002490, M160,170 etc. Where do I check these nombers?



I check the licence from Help-->Technical Info.

Here it shows various licences like Pro/Surface, ProMesh etc. Is there
any option here to check the licence for Parasolid import?



Thanks,



Keyur
 

xcad

Member
Under Help>Technical support info write us down the :


Pro/ENGINEER Date Code : (that's for proe)


for parasolid search for :


Modeller: TRANSMIT FILE created by modeller version: (.............) , on the log file


Search also for the size of your parasolid file... it seems to me that maybe the parasolid has problems... have you tried to open it with another software> SW or SolidEdge, UG, and so on?



Edited by: xcad
 

mstols

New member
Check your file names. there should be no spaces in the names and keep it as short as possible.
 

keyurkanade2

New member
Hi,



I found Pro/ENGINEER Date Code under technical support
information. It is seven digit number. I do not know if I can disclose
these numbers. Does any specific digit in this number belongs to
Parasolid import? If yes which is it?



Thanks,



Keyur
 

Moroso

New member
keyurkanade2


Did you try what mstols said about the spaces?


In an early version of Wildfire 1.0 you couldn't import parasolids you had to apply a config statement that escapes me at the moment import_parasolid or something.
 

dr_gallup

Moderator
The message "No files or directories found" comes from using the File\Open command in a directory that has no Pro/E files, it has nothing to do with your success or failure in opening a *.x_t file. You should be able to change the file type in the File\Open dialog box to All Files(*) and open the *.x_t file. Nothing more is required. Parts will open as parts and assemblies will open as assemblies.

Be prepared for Pro/E to tell you "WARNING: Design intent is unclear in your_file_name. Use "Info"/"Geom Check" in Part mode." This happens with every *.x_t file I have. Probably an accuracy issue. Also be prepared for your imported model to consist of a coordinate system and one big lump of dumb geometry. No features, no parametrics. This is a long way from what I would consider useful data exchange. No better than IGES or STEP.
Edited by: dr_gallup
 

keyurkanade2

New member
Hi,



I changed the file type to *x_t. It shows me my parasolid files. These
file names does not have any spaces. Also the file names are of only
eight characters.



Is there any option to be set for parasolid import as Mr. Moroso pointed out.



Regards,



Keyur
 

Moroso

New member
If your seeing the file than adding somehing to the config probably won't help.


Can you post one of the troubling files here in a post, my email won't let in anything bigger than 2 mb's


I'd be glad to try it here for you but you might have confidentiality issues if it a clients file.


Brian
 

keyurkanade2

New member
Hi,



I can not post the file as they are confidential. If you tell me that
'this this' licence is required for parasolid import, I can ask our
System Manager to buy this licence.



Thanks,



Keyur
 

Sponsor

Top