Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

Fadal problems

lcl

New member
Hi all,


I use fadal VMC milling centers, with CNC88 controls, and I, generally work in Inches.


My problem is that my machines does not goes directly from one point to another when a G0 is found, but makes an angle and then a line paralel to the X or Y axis. This causes me a lot of problems and weld.


What I generally do is manually edit my programs and change all the "G0", between the header and the footer of the program, to "G1 F300.". This for me is a problem because is a waste of time and a possibility of commiting mistakes.


Does anyone knows how to change the post processor to do this job automaticly??


thanks


Luis Cunha Lima
 

cncwhiz

New member
I think you should look at the machine before you edit your post. I am sure that there is a parameter that will allow you to change this funtion, but it seems like you are taking away from on feature to give it to another. If your rapid rate is at least 400 ipm you are loosing 100 ipm of rapid which can add on a lot of cycle time if the job is long. Slowing cycle time down is always bad. You shouldvisit some other options before you do this, but if you need to do this I would test it in the parameters of the nc sequence. I you build sites you will not kill your post if you want to use rapid in the future that will change your rapid from default to 300 ipm?


 

marker4x4

New member
lcl said:
My problem is that my machines does not goes directly from
one point to another when a G0 is found, but makes an angle and then a
line paralel to the X or Y axis....


This sounds perfectly normal to me; it's called "doglegged" movement
and it's common for inexpensive (or older) machines such as Fadal or
Haas.



I know in some cases it can be a nuissance, but if you set your
clearance plane well above the part (or fixture or whatever might be on
the way) you should be fine with G00 doing it's own things.



I hope it helps
 

chf65

New member
Hi Luis,


If you were not able to set your Fadal settings to "time move" in rapid, you have 2 solutions:


- change the post, to output Rapid moves in high G01 speed.


OR (even easier)


- in Pro/NC sequences, set the FREE_FEED parameter = 300 (per default it is 0, which ends up a RAPID move). If it is the only way you work, you can set a Site to default all your sequences to this value.


Hope this helps,


Charles
 

Sponsor

Top