Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

Drawing Templates in Intralink 3.3

phwarren

New member
Hello all:



We just updated to wildfire and Intralink 3.3. I tried to use my old drawing templates in 3.3 by moving them to the /pdm/templates directory. When I try to create a new part or assy in intralink with the object - new command, I get the following error:



View attachment 104



I went to the knowledge base, and found the following:



***********************

Description

-----------------

If The default template contains an attribute with illegal value (i.e. a value which is NOT in the attribute's list of values), selecting #Object #New in the Workspace will return the non-Descriptive error message: 'An invalid handle WSPIHandle Was Passed To An API Function PDMWSPISetCurrWSPIVTargetFolder'





Alternate Technique

-----------------

Add the illegal value to parameter's list in Pro/ADMIN, or modify the template.





Resolution

-----------------

This issue will be resolved in Pro/INTRALINK 3.3 M020.

******************



I tried creating a brand new template file in Wildfire from scratch and placing it in the templates directory, but I still get the same error.



Any help would be greatly appreciated.



Phil
 

mmead0ws

New member
Have you tried checking in the templates into Pro/INTRALINK? Wildfire and 3.3 allow you to maintain your templates in the COMMONSPACE. Just set your start_model_dir to the folder in the COMMONSPACE. To get the syntax right, browse for the location. You can also set the options for the default part, assembly, and drawing templates to the commonspace.



If you really want to use the PDM/Templates location, try checking in the templates anyway and see if you get a more descriptive error. You can always delete the templates back out of the COMMONSPACE.



Good luck!
 

cncwhiz

New member
PHwarren,

I know that this might be a dumb question, but did you install all that patches from last months problem. I know that there are two for Intralink 3.3. And depending on you wildfire their may be one there as well. We use Intralink and are getting ready to have the rest of the guys here change to it. I have been the crash test dummy for drawing,assys and pro manufacturing and have had no problems outside of intralink?
 

proed

Moderator
Have you checked that all the template's default parameter values are in the allowable lists or ranges of values?

eg: material type, designer, etc...
 

phwarren

New member
Thanks for the help....



cncwhiz - We just installed Ilink 3.3 and Wildfire last week, so I assume we are using the latest build (451 for Wildfire, 290 for Intralink)



proed - How do I know what parameter values are allowable?? When I first got this error messages I was using the exact templates from ProE 2001. I decided to open the templates in Wildfire and save them in wildfire, just in case they needed to be updated. They still gave me the same problem. Then, I created two brand new parts in wildfire with no parameters and placed them in the intralink directory. Still got the same error message.
 

Brian_Adkins

Moderator
Go into Pro/Admin to see which attributes Pro/Intralink will be tracking for each object. These are the attributes that should be designated in your Pro/E models.



Admin / Object / Attributes / Object Attributes



You problem 'could' be caused by other designated Pro/E parameters that Intralink is not 'expecting' to see. Intralink 3.1 will give you the following error when saving a model that has extra parameters which are designated:

The following attribute definition(s) are not among FileBased in Pro/Intralink:



maybe this is a similar problem?



-Brian
 

phwarren

New member
I checked in my Admin - object attributes and there are 5 parameters listed there... I have all 5 designated in the template parts and assemblies. No other parameters are designated in the templates.
 

phwarren

New member
Thanks for the help everyone...



I called PTC and they fixed my problem.. It was the updated dll files from the patch back in January.
 

Sponsor

Top