Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

Config.Pro Slow Sketcher

Gtalmond

New member
Ok, i did my homework, searched everywhere for info about whats giving me a slow sketcher.



Some people say it might be my graphics card, and to change the config.pro to GRAPHICS WIN32_GDI.



I opened up my text editor and added the option at the end of my config.pros because there are two of them.



However, i still have a very slow sketcher.

Here are my sys specs.



Windows XP Home

P4 2.8 GHZ 533 FSB

512 MB Ram

80 GIG Hard Drive

9600 XT ATI Radeon Graphics accelerator card.



Many people would say that it is my graphics card, however, changing
the config.pro to GRAPHICS WIN32_GDI should cause a software render.



Is there anything else i should look into?



Or perhaps am i changing the config.pro incorrectly.



Please Help

Thank you very much

Gtalmond
 

goosemonster

New member
Two real basic things spring to mind,


1. Make sure your graphics card in running the driver specified by PTC (this may not be the 'latest' driver from ATI.


2. Stick more RAM in your system. 512 may be enough to get by on but you should have at least 1024.





Thanks


Andy
 

puppet

Moderator
A friend of min had a similar problem, and it was a matter of graphics, play with these options





- Colour depth .. 16bit/32bit/(matrox cards) 24bit



- screen resolution... might be too high or even too low, yeah to low can stuff things up too



- refresh rate.





hope that helps
 

Brian_Adkins

Moderator
I've had sketcher graphics problems in the past caused by mouse cursor bells & whistles... Make sure you're not using the standardwindows cursors and not some tweaked out set. Also, turn off any special cursor effects such as "cursor shadow", mouse trails etc.


-Brian
 

Gtalmond

New member
I was talking to my ENES 100 instructer, he said that the previous year was having the same problems, perhaps it is my Pro/E Version?


I have 2003100, the dreaded timeout version.


I've been petitioning to get a new tryout version from PTC, but so farI have yet to recieve anything.


Is there any possible link to my problem and the software version?





Thanks,


Gtalmond
 

Gtalmond

New member
I ended up updating my drivers, turns out ATI had a brand new Catalyst driver. It fixed it, so much much more better



Thanks so much.

Gtalmond
 

Bjorden

New member
I'm having the same problem. using win32_gdi makes my pc reboot or suddenly exit Pro/e. It is fast when viewing assemblies or parts in 3d, but sketching is very slow. I use wildfire 1.0. Anti Aliasing on or of doesn't make a differance in sketching speed.


specs:


Athlon 3700+ @2900 MHz


Ati Radeon X800Pro 256 MB (Asus)


1024 MB ram
 

Isair

New member
This all is problem with ATI based graphic cards, because they aren't based on OpenGL, they are based on DirectX, and ProE is based on OpenGL.


Right way to solve this problems is to avoid ATI graphic cards for ProE use. As if you already have ATI then only way you can do is to mess with drivers, and maybe tweak regular graphic card to professional FireGL graphic card (of course you are doing on your own responsibility; and inevitable before messing with drivers make system restore point).
Here is link to site where are all kind of drivers and guide how to tweak graphic cards:
http://www.guru3d.com/
 

appinmi

New member
I have been using Pro/e since Rev. 9 and have allways set my graphics in config.pro to "GRAPHICS OPENGL". I have never had any problems with a slow sketcher with any graphics card that I have used. Since most good graphics crads, and even semi-good ones support OpenGL graphics, why not try it?
 

Brian_Adkins

Moderator
ATI and NVidia both make excellent OpenGL cards. THey also both make low-end gaming cards that are not always up the the task of 3D CAD.


Using the config.pro option "GRAPHICS OPENGL" won't hurt, but this is the default if your card supports opengl and this option is not really required.


If you are experiencing slow sketcher performance or other graphics-related issues, including a STD.ERR output file containing "RAISING SIGNAL 11", try upgrading to newer graphics drivers.


In my past 12 years of Pro/E work, I'm still astonished how often this simple step fixes problems.


-Brian
 

Sponsor

Top