Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

Can't See FlexLM Thru Router

G

Guest

Guest
I have 2 desktop computers hooked up to a router. The FlexLM license server is on Computer A. I can run Pro/E just fine on that computer. Computer B, which can share files with Computer A through the LAN and can see Computer A in every other case, cannot see the FlexLM license server. All my firewalls have been disabled. I am using DHCP from my router to my ISP, and DHCP from my computer to the router. If I try switching to a static IP from my computer to the router, I cut off all network connections.



Any suggestions? Thanks in advance.
 

Brian_Adkins

Moderator
Jason,



Can you ping A from B using the hostname of A... how about ping using A's IP address?



What are you entering as the hostname in the Pro/E setup of machine B (IP address, hostname, etc.)



-Brian
 
G

Guest

Guest
Yes, I can ping A from B using the hostname of A and the IP address. I have tried entering both the host name and the IP address of the host computer during setup to no avail.



I have also tried various settings on my router...
 

pjw

Member
Try adding the IP address of the host to your hosts file which can be found in the following location:



C:\WINDOWS\system32\drivers\etc



e.g.:



194.36.140.201 exchange0

194.36.140.66 win2000.fortvale.com

194.36.139.205 design2000



You will obtain your IP address after you have 'pinged'. Hope this might help.
 

dhbigelow

New member
As memory serves, I think the server needs an IP - not sure why this was, maybe a glitch in the FlexLM depending on the version.



Also - you might want to check/verify that your ports for PTC/FlexLM are forwarding within the router if you are not using routable IPs.



These are long shots - but you never know..



Dave
 

aandersen

New member
If I am correct, by default FLEXlm uses port 7788 so you will need to make sure that you open port 7788 in your router.



I am sure you know that DHCP LANs are not supported so it would be better to use static IPs to use to try to keep in line with recommended techniques.

You should be able to set up static IP's without loosing your network connectivity. Can you explain how you have it set up when attempting to do so.
 

phildunn

New member
After doing a lot of research into making our ProE licenses avalible over the internet I found that you need to edit your license file to get it to work (I think this may also apply if your sever is on a different subnet).



Go into the licence file and find the line sarting with DAEMON, it should be near the top, at the end of this line add PORT=7789

eg

SERVER myserver PTC_HOSTID=00-....-C7 7788

DAEMON ptc_d /usr/.../obj/ptc_d /usr/../ptc.opt PORT=7789



You'll need to restart flexlm with the modified file.

From memory the PORT=7789 forces communication in one direction to that port as oppose to something else??? If you are going through a firewall you need to allow traffic through on 7788 and 7789 (I can't remember which direction is which port, I allow both in and out). This should then allow anyone with access to those ports to pick up a licence from anywhere.



We've got people dialing up from home picking up licences on accounts from various ISPs without any problems.

Hope this helps

Phil
 
G

Guest

Guest
Thanks for everyone's help. Everyone's suggestions were valid. However, my problem was with other programs installed on the computer that had firewall applications of their own. The following TAN from PTC explains the problem:



The issue is caused by a conflict with the firewall/VPN client software installed on the computer.

The following types of firewall software are known to cause this conflict:

Microsoft Firewall client

Sygate Personal Firewall 4.2

Freedom

McAfee 7.0

Micosoft Zone alarm

ATguard

Norton Internet Security

Norton Corporate Edition





See http://www.ptc.com/cs/tan/115722.htm for the full explanation.





I tried the following programs on the computer, each of which prevented FlexLM from running correctly.



* McAfee Antivirus 7.0 ( They claim 8.0 resolves this problem. See http://ts.mcafeehelp.com/displaydoc.asp?docid=96491&CategoryId=243 )



* McAfee Privacy Service



* CyberPatrol 6 ( http://www.cyberpatrol.com )





The solution is to uninstall all of these programs, use Pro/E 2001 with a build earlier than 2001440, or wait until the production release of Wildfire 2.0.



Note: I am now running Norton AntiVirus 2004 and FlexLM is having no problem with it.
 

mkaltenborn

New member
I have established a VPN from home to office and installed ProE Wildfire at home. During the installation the license file was selected by browsing the office with the primary installation of ProE. When I attempt to start ProE at home the license cannot be found. Does anyone have an idea what may be happening?
 
G

Guest

Guest
I don't know about the previous question about the VPN. However, today we had a Pro/E issue in where it behaved similar to the situation described in this thread, in that we could ping the license server, but would get a invalid license from it. We tried everything to get it to work, but to no avail. Finally we ran Adaware (a software program designed to remove spyware from your computer). It found a lot of spyware, and after the spyware was removed, Pro/E could communicate with the license server and it worked fine.



Beware of spyware - use Adaware (or equivalent)

http://www.lavasoftusa.com
 
G

Guest

Guest
In general, spyware is any technology that aids in gathering information about a person or organization without their knowledge. On the Internet, spyware is programming that is put in someone's computer to secretly gather information about the user and relay it to advertisers or other interested parties. Spyware can get in a computer as a software virus or as the result of installing a new program.



-- http://searchcrm.techtarget.com/sDefinition/0,,sid11_gci214518,00.html





Most people are familiar with freeware, shareware, cookies, media players, interactive content, and file sharing. What they may not realize is that some of the aforementioned may contain code or components that allow the developers of these applications and tools to actually collect and disseminate information about those using them.



They can track your surfing habits, abuse your Internet connection by sending this data to a third party, profile your shopping preferences, hijack your browser start page or pages, alter important system files, and can do this without your knowledge or permission. The security and privacy implications of these exploits should be quite obvious and undesirable on any system or network!



-- http://www.lavasoftusa.com
 

martingh

New member
I think you should try to adding the IP address of the host
to your hosts file. You will find that in the following
location:

C:\WINDOWS\system32\drivers\etc

Try this one; it will help!!

RBS
Edited by: martingh
 

Sponsor

Top