Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

Assistance with pro/batch required, pls


New member
i am trying to convert about 100 pro/e wildfire 2 files to step for a
contractor. i have read just about everthing that i can find on
the internet including the PTC tech support documents. I cant get
this thing to work.

can sombody please help me out. I am entering all the parameters
that i think i require, the batch process appears to start, but
computer doesn't sound like its working very hard. after a few
seconds the batch process completes, but has not produced anything.

thanks in advance

arlen nelson.


New member

Try the following.

Before you use Pro/Batch, make sure that all the files that you want to export can be opened without any features failing.

If you want to use Pro/Batch often, I would recommend that you set it
up to work on your mouses right click. If you do this you can easily
control the way that probatch works.

This is how you set Pro/Batch to work on the right click of your mouse:

Open windows Explorer.


Click on FILE TYPES.

Go down the list untill you get FILE FOLDER.

Select it and click on ADVANCED.

Click on New.

Type the command that you want to use in the Action window. (Ex PRO-BATCH)

Click on Browse, and browse to the BIN directory in your Pro Engineer instalation folder.

Double click on the PRO_BATCH.BAT file to at it to the window.

You Command should look something like this.


Type a space and a * behind the .bat. this will specify that Pro/Batch must start and function in the folder that you specify.

Your final command should look like this.

D:\Ptc\proeWildfire2\bin\pro_batch.bat *

Click on OK, OK, Close.

If you open you windows explorer window, browse to the folder that contains the files that you want to work on.

Right click on the folder in the lefthand column, and you will see your
Pro/batch start command. Click on it to start probatch in that folder.
Make sure that there is NO SPACES in the folder names as probatch will
not start up if there is any spaces. Replace all spaces with a _

I would advise you to copy your config.pro and config.win into this
folder before you start probatch. This will enable pro engineer to run
in the normal way that you would use it when you create models. If you
want to plot with probatch, You might get to the point where you want
to create plots using your standard PCF(Plotter configuration) files.
IF you have some config.pro option for exporting of your step files, it
will enable proe to run with this config file.

Ok, now lets use PRO/Batch.

Click on the OPEN BROWSER icon. Because you started Probatch with the
mouse right click, you will see that the File Browser window opens in
the specified directory.

Select all the files that you want to work with, And select ADD OBJECTS.

Select all the files in the main probatch window.

Right click, go to SET action and select the action that you want to apply to the files.

If you've selected STEP, You will see that it shows STEP in the action column next to every file.

Then you need to specify a name for the bath job that you want to do.

In the bottom left hand corner specifiy a name. Something like "STEP_FILES"

In the bottom right hand corner, you need to specify your proe start up command.


For wildfire the default command is PROE1.BAT.

If you dont' know how to get to the startup command, do the following.

Go to the bin directory in your pro engineer instalation directory. In
this directory you wil find a PTCSETUP.BAT file double click on this
file. this will open a window that is similar to the window that you
see when you install the software.

Click next untill you get to the window where you see the license configuration window.View attachment 985

Double click on the license type to open the select license window.

Then you will see the configuration name. Normally proe1.

View attachment 986

NOW your Pro/Batch window Should look something like this.

View attachment 987

Click on the save button to save. Click on the RUN BATCH FILE icon.
Click on OK if you want to start the proccess without specifying a
scedule time.

The Pro batch run window will open with a status of running. Be
patient. Remember that Proe is starting up with a non graphical
interface and also needs to open all these files as well. A dos window
will pop up when the proe is running. do not close this window.

When the batch job is done, The status will show as FINISHED. See the two windows below.

View attachment 988

Pro Batch will have created all the files in the same directory that you started pro batch in.

Remember that Pro batch Uses a proe license to run. Make sure that you have a available license before you start the run.

Hope this helped.


New member

If the file type doesn't work how do you go about deleting it.

When i double click on a file folder it puts me into the search command instead of opening the file folder, how is it possible to get back to or get rid of the file type created

Thank you


New member

Make sure you do the following steps correct. If you dont you will reload your operationg system.

Click on start, Run. Type REGEDIT. and click on ok.

The registry editor will open. To be save, export the registry to keep a copy. Select on the my computer in the registry editor. click on file export and export your whole registry file to your disk.

Click on edit find. and type the name of the command that you want to remove.

It will be in a location like HKey_CLASSES_ROOT\FOLDER\SHELL\......

Your command will show as a folder on the left hand column. You cand delete this folder to remove the command. or you can fix it by expanding the folder. click on the COMMAND folder.

View attachment 1007

Double click on the key in the right column to open it. You can change the patch to the pro/batch command to fix it.

It should look something like the to work.

D:\ptc\proeWildfire2\bin\pro_batch.bat *

Remove the %1 that has been added at the back.

The reason that your explorer goes into search mode when you double click on a folder, is because you added the option to windows.

THIS is a bug in Micorosoft windows. Yes I said windows. It also has bugs, just like Proe.

To Fix this do the following in that same registry window. Go up one level in the folders to the SHELL folder.

View attachment 1008

Double click on The key in the right column.

Type none in the value field.

View attachment 1009

This will allow windows to open a folder instead of searching in a folder when you double click on a folder.

Every time you add an opne manually to the right click. you have to type the "none" into this key.

Hope this helps.



New member
When does it give you this error.

When you start probatch or when you run it.

To check if probatch is working, you can go to the bin folder in your wildfire installation. Double click on the pro_batch.bat file and pro batch should start up.



New member

Then it is your Proe start command. Probatch is unable to lacte the batch command that needs to start up PROE. This could be due that you've specified an inavalid start command, or it could also be if you've installed proe in the default program files folder. Probatch is still developed to run in the unix enviorment. So you can have no spaces in your folder paths.


New member
Yes In my system it is installed in Programme files\ProeWildfire.I am using Windows OS ONLY. Is there any solution?

Edited by: mg_ayyanar2000


New member
Re-install wildfire to something like the following.


make sure ther is NO spaces in the full path.


New member
I know this is an older post but for a new guy it was very helpful. Thanks to all involved. Worked for wildfire 4 fyi.