Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

assembly x-sections

brunoware

New member
I have the following problem: I want to create a x-section of an assembly (I created a simple example):
View attachment 547

In order to exclude one component (the small ring) from the total x-section I used the "excl comp" from the "mod xhatch" menu.

and this is my result:

View attachment 548

I shouldn't see the xhatching below the excluded component!

brunoware
 

arroyopr

New member
View attachment 549Hi bruno:


Go to asm. then click on the view manager, xsection. new,then select if you want it offset or planar, then click on the datum or sketch. when you r ready to insert the view, the x-sec. will appear in the view prop.after setting your xsec. select the comp.to exclude then go to view rep. exclueView attachment 550
Edited by: arroyopr
 

brunoware

New member
Thank you for your answers but:


* aerohead34: I forgot to tell you that I am using the WF2.0;

* arroyopr: I couldn't easily understand your answer: what do you mean for "select the comp.to exclude then go to view rep. exclue" do I have to create a simplified representation

my question was:

Is this the only way to exclude a component from an assembly xsec?
"Click MOD XHATCH > Excl Comp to remove a component from the cross section display"

Ref: Pro/engineer Help Center

Thank you
 

arroyopr

New member



If you just don't want to show the part just select the part and hide it. It doesn't matter if is a xsection or what ever is the view.
 

brunoware

New member
Thanks but...

As I posted in my first message my problem is related to the x-section visualization.

Referring to the second image of the first posted message (the one with the black background). I would expect NOT to see the x-hatching under the ecluded component (the ring).

So, insted of this:


View attachment 570

I would expect to see this:

View attachment 571

brunoware
 

dibloff

New member
View attachment 585Hi.


You should see the shaft's xsection, since the ring is not cutting the shaft in that area.I think is your problem, that the ring shall cover the shaft in that area. Go andright-click on the view -->properties -->View display and choose display style -no hidden, and tan edges - dimmed. Then right click on the x section, and exclude the ring. Then go view update current sheet. It shall work. See my shaft-explanation.


Attila


View attachment 586
 

xcad

Member



i cannot understand this post


this function works well in proe wf2


double click on the xsec, use the exclude component option


set the display to no hidden and the result is fine.... where is the problem on that ?
Edited by: xcad
 

skraba

New member
Based on the picture you paste it, is it possible, your view is showing wireframe model? Try to set No Hidden or Hidden lines to show (View Display menu in the 2001 version).
 

tinag

New member
Hi Bruno,


The x-hatching u r seeing is the x-sec for the cylinder, notice there are not hatching lines on the ring. you will see these if the cylinder is solid. Because the ring only circumfrencies the cylinder, it will not exlude the area which you are trying to remove. you must first make the ring into a solid disc, cutting thru the cylinder itself before the hatching will dissappear.
 

brunoware

New member
I have finally found out the cause of my delirium:

In the Drawing Setup File the option crossec_type was set on new_style.

I changed to old style on now all is fine.

Thank you all for your patience.
 

Sponsor

Top