Results 1 to 5 of 5
  1. #1

    Creo 4 startup directory

    For every version of Pro/E I've always had a shortcut that called a batch file that launches Pro/E. In the properties of the shortcut I set a Start In folder which is the top directory where all our models are stored (no PDM system). This still works just fine for WF2 and Creo 2. However, setting the Start In folder has no effect for Creo 4 (we are using M020), it always starts in My Documents. Anybody know why and more importantly how to fix this behavior?

    Click image for larger version. 

Name:	Capture.JPG 
Views:	5 
Size:	14.3 KB 
ID:	6984
    PTC quality philosophy: We've upped our quality standards. Up yours.

  2. #2
    Following ---- I will try to take a look on Monday.
    Mike

  3. #3
    Have you checked the value of the config option file_open_default_folder? As I recall, starting about Creo 1, I believe, the default folder shown was set to the My Documents folder. Something about Windows compliance I believe. Your working directory is likely set correctly, you just need to set file_open_default_folder to working_directory.

    Another remote possibility is that your custom startup batch file is changing the directory it is running in. Creo will set the working directory based on the folder that is active at the end of your custom startup batch file. That effectively sets the folder that Creo is started in. The icon property only sets the folder that your custom startup batch file is started in. Most people don't change folders in their startup batch file and, unless yours changed when you went to Creo 4, it would have done this with Creo 2 & WF2 as well.
    Doug Schaefer | Director of Design and Engineering
    Concept Engineering | Columbus, OH

    614.279.8771 | www.conceptengr.com

  4. #4
    Thanks! I added this line to my personal config.pro and that solved the problem.

    file_open_default_folder working_directory

    I did not have that option set to anything before and it's not set in any of the WF or Creo installation directories so they must have changed the default behavior.

    I really need to spend some time configuring Creo 4. It's just not part of my job description anymore but no one else is doing it either.


    Quote Originally Posted by dgs View Post
    Have you checked the value of the config option file_open_default_folder? As I recall, starting about Creo 1, I believe, the default folder shown was set to the My Documents folder. Something about Windows compliance I believe. Your working directory is likely set correctly, you just need to set file_open_default_folder to working_directory.

    Another remote possibility is that your custom startup batch file is changing the directory it is running in. Creo will set the working directory based on the folder that is active at the end of your custom startup batch file. That effectively sets the folder that Creo is started in. The icon property only sets the folder that your custom startup batch file is started in. Most people don't change folders in their startup batch file and, unless yours changed when you went to Creo 4, it would have done this with Creo 2 & WF2 as well.
    PTC quality philosophy: We've upped our quality standards. Up yours.

  5. #5
    Doug is one very good person, for help here on this site.

    I noticed you are referring to Creo 4.0 if you use the mold part. I advise you to add these three settings too.

    dm_verify_subtype = yes (hidden setting)

    display_mfg_icon_for_mfg_assy = yes

    ENABLE_CLASSIC_MOLD_TOOLS = yes (hidden setting)

    Note: the two hidden settings /// Good old PTC seemed to over look proofreading the mold updates and at least added a couple of hidded settings to resolve the issues.

    Just like your sig --- PTC quality philosophy: We've upped our quality standards. Up yours
    Last edited by canoemike; 09-25-2018 at 10:01 PM.
    Mike

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •