Results 1 to 3 of 3
  1. #1

    CREO Parametric 4.0 M010 installation issues with Universal C Runtime

    Hi all, I'm having an issue with the latest PTC installer for CREO 4.0 M010, but also for Mathcad Prime 4.0.

    What happens is that as soon as I run the installer it asks me to install Universal C Runtime, I go to the site, download KB2999226 but when I try to install it's already installed.

    I opened a ticket on Mathcad and one one Creo, followed all the suggestions, my system is Windows 7 SP1, all Windows Updates are installed, I uninstalled and admin-reinstalled KB2999226, installed .Net 4.6.2 and even Windows 10 SDK. Nothing works, and I'm still unable to run the installer.

    Anyone had this issue? The latest feedback from the tech support is that they elevated it to a SPR because not all users want to do all the updates, and they want to track down the updates that are necessary to make the installer work. That won't help me in any way because I already have ALL the updates so there must be an issue somewhere, in Windows Update or in the Installer. I imagined they could check some logs from the installer but no one on the tech support mentioned it so I suspect they really have no clue :O

  2. #2
    Have you tried disabling your virus software during the install?

  3. #3
    You're not alone with this one. I called support and they said quite a few other people are having the same problem and that PTC are working on it. They said re-install F000.

    There are the following posts on the PTC Communities page that might be worth following but I'll try and remember to put an update on here if I get anywhere.


    Beyond the Mouse

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts