Results 1 to 5 of 5
  1. #1

    Part reset after close, CREO

    Hi

    Really hope you can help, as no one at my work has ever encountered this issue.

    I a creating a assembly, with 5 parts, each generated with family table, consisting of 18 parts each. so 5x18 parts

    i have created an assembly of the generic models, and have later decided that i need to edit some tapholes placement on the base model of the assembly (the one the others are mated around, not that i think that matters).

    What happens is: I can adjust my sketch for pattern, and therefore move the cut holes as i please, veryfying and saving the model with the new placement, is not a problem, i can even regenerate the model in assembly, still no complaints from Creo.. The problem is that when i save, and close it all, and upon reopening the file, everything is back to "normal", like its a read only file, with temporary modification. I have tried making a simple cut or extrude without pattern, but the same story, i can make the feature, verify on family table regenerate in assembly and save and exit with problems, or error messages, but when i open again, back to "normal". i have moved these holes and patterns on 2 others parts in the assembly, since they needed to match, and nothing here, just a simple verify and everything worked as it was supposed to.

    The best regards
    Simon

  2. #2
    I can't check it right now but some feature changess in family tables' childs only have temporary effects. Keep an eye on the message window of CREO for any warning...

  3. #3
    i have checked the files during saving etc. and there isn't any warning at any childs.

    A colleague had a solution, to edit the feature, and then go to assembly, and save all parts as assembly as a backup-file on the drive. Then create a new work space, and open the backup assembly in this workspace, and regenerate the family tables, this did work, but none of the 90 drawings and dxf files followed adding up to 180 files i have to do again, if not fixed otherwise.

    So if you have a solution, where i can fix the model in the current workspace this would be most appreciated! or a solution to move the drawings to the new workspace, and link the to the "new" files.

  4. #4
    Are you working with a data manager like windchill?
    Ron

  5. #5
    Yes we are using Windchill - and tried every aspect, even have a administrator to search for similar file / name, but nothing, so it did the upload as intended as well.
    i have now created a copy of the asm and childs, cleared workspace and edited the tapholes and patterns, and it worked finally! But imo it seemed like a loooong way to go for it, especially since i had to redo all drawings for the 90+ parts..

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •