Welcome to MCAD Central

Join our MCAD Central community forums, the largest resource for MCAD (Mechanical Computer-Aided Design) professionals, including files, forums, jobs, articles, calendar, and more.

Register Log in

’ASM0001’ error message

tazanddoll

New member
Greetings,


can anyone tell me what " 'ASM0001' cannot be retrieved" means in the Message Log when I'm opening an assembly??? - it seems to be calling out the ASM0001 assembly even though there is no such sub-assembly or part within my assembly.


- confused and fustrated...
 

Israr

Active member
Can you attach your message log file here such that I can help you.


May be its your working directory problem, or when the assembly was saved last time you or somebody created a new assembly and then saved it while there was your assemblyalready open in the working directory.


Israr
 

arroyopr

New member
like Israr mention it looks to me that somebody else had the same asm. open when you have it in session. and it created a new one. And is creating a missing components problems, that's why it can not retieve the parts, becuase is in a diferentdirectory.
 

Surflaunch

New member
Sounds likethe original ASM001.asm file was saved in the wrong workspace and now is not available. Do a search for that file name on your system and see if it exists somewhere. If it does then copy it to your current workspace. If it does not exist then create a blank one and save it in your current workspace. That should allow you to at least get back in the parent .asm or .drw file. You might have to re-do any work that was in the ASM001.asm file if you have to make a blank.


Good Luck,


Fred DeArment


Hatteras Yachts engineering
 

tazanddoll

New member
Thanks guys..


tried creating asm0001.asm in workspace... sometimes it works (no error message when pulling up assemby, and sometimes I still get the same damn error message.
 

donha

New member
asm0001.asm is the default assembly name Pro/E will assign to an assembly if the name is not changed in the create assy dialog box. The same is true of prt0001.prt, Pro/E default for in session part naming. If asm0001.asmdoes not exist anywhere, you were correct in attempting to creat a dummy assy, butwhat component would be missing from your assembly? Perhaps you can get lucky and whoever made the assembly, will have put all components on layers. Perhaps those layer names would make sense according to part/asm? In your case, the layer which had nothing on it, would be the missing component. Also, you can take a look at your trail file anddetermine the component before the missing component as well as the component after the missing component and possibly make a judgement call to what the missing component would be. Perhaps you have a BOM and can figure out which component is missing? Sorry, no easy answers here.
 

Sponsor

Top