Results 1 to 2 of 2
  1. #1

    Weight Value in Repeat Region - Assembly Drawing

    I am looking for advice on displaying weight for each family table instance on my assembly drawing. This weight may be used as a general estimate for product shipping.

    My current setup,
    I have a relation: weight=mp_mass(quotequote) in the assembly model and all part models.
    I put the relation created parameter 'weight' into the family table.
    I have had issues with the calculations in the family table. It can require multiple regenerations and family table verifications. In some cases requiring opening and manually regenerating each family table instance. For these reasons, I am exploring other options.
    I display the 'weight' parameter in my repeat region table using the report symbol &fam.inst.param.value and filter &fam.inst.param.value == 'weight'

    I have read several threads about using Creo's built-in mass parameter (pro_mp_mass) instead of the old method mp_mass(quotequote). I have also read tips that a relation created real number parameter should not be used in the family table.

    My current experiment,
    I have tried the relation weight=pro_mp_mass in both the assembly and part models.
    I can recall the parameter within a repeat region table for PART drawings. No problem.
    I use the report symbol &mbr.(user defined)weight and the units &mbr.ptc_units(user defined)weight

    Questions:
    Do I in fact need a relation that equals pro_mp_mass or can I call that parameter directly in the repeat region on the drawing?
    How do you recall the correct report symbol for an instance in an ASSEMBLY drawing repeat region?

    I am trying this in the assembly drawing and I am unable to figure it out.
    &asm.mbr.(user defined)weight pulls in the weight value for a single component. I am interested in the entire assembly weight for the family table instance.

    My table is a single column repeat region (not 2-d).

    I am currently on Creo 2.0 M110.

    I appreciate the help in advance!

    Wes

  2. #2
    I also have a BOM table with component weights. But after regen, this table shows the weight of the component AFTER any assembly cuts.
    I would like the table to pull the value of the component parameter to show the weight of the component as it comes "TO" the assembly station. Before any assembly cuts. I cannot get the .cparam.... to work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •