Results 1 to 4 of 4
  1. #1

    ECAD Swap for asm file

    Hi,
    I’m trying to swap an ecad component for a pro/e assembly rather than a part, however pro/e is only creating a part with the assembly name that I want it to use?

    Have we lost the ability to swap pro/e assemblies in ECAD?

    Sample:
    #
    map_objects_by_name->
    ECAD_NAME "SW_TL1105"
    ECAD_ALT_NAME "SW_TL1105EF160Q"
    ECAD_TYPE ""
    MCAD_NAME "SW_TL1105EFXXXX"
    MCAD_TYPE "asm"
    MCAD_LAYER "SW_TL1105_SW_TL1105EF160Q"
    END
    #

    Note: I have tried the MCAD_TYPE as “asm” “assm” “assy” “asy”
    But rather than pulling in the pro/e assembly in it creates a part with the mcad name?

    Any suggestions?

  2. #2
    Quote Originally Posted by D. Urban View Post
    Hi,
    I’m trying to swap an ecad component for a pro/e assembly rather than a part, however pro/e is only creating a part with the assembly name that I want it to use?

    Have we lost the ability to swap pro/e assemblies in ECAD?

    Sample:
    #
    map_objects_by_name->
    ECAD_NAME "SW_TL1105"
    ECAD_ALT_NAME "SW_TL1105EF160Q"
    ECAD_TYPE ""
    MCAD_NAME "SW_TL1105EFXXXX"
    MCAD_TYPE "asm"
    MCAD_LAYER "SW_TL1105_SW_TL1105EF160Q"
    END
    #

    Note: I have tried the MCAD_TYPE as “asm” “assm” “assy” “asy”
    But rather than pulling in the pro/e assembly in it creates a part with the mcad name?

    Any suggestions?
    Found it:
    Must use:
    MCAD_TYPE "asssembly"

  3. #3
    Found it!
    Must use MCAD_TYPE "assembly"

  4. #4
    Quote Originally Posted by D. Urban View Post
    Hi,
    I’m trying to swap an ecad component for a pro/e assembly rather than a part, however pro/e is only creating a part with the assembly name that I want it to use?

    Have we lost the ability to swap pro/e assemblies in ECAD?

    Sample:
    #
    map_objects_by_name->
    ECAD_NAME "SW_TL1105"
    ECAD_ALT_NAME "SW_TL1105EF160Q"
    ECAD_TYPE ""
    MCAD_NAME "SW_TL1105EFXXXX"
    MCAD_TYPE "asm"
    MCAD_LAYER "SW_TL1105_SW_TL1105EF160Q"
    END
    #

    Note: I have tried the MCAD_TYPE as “asm” “assm” “assy” “asy”
    But rather than pulling in the pro/e assembly in it creates a part with the mcad name?

    Any suggestions?
    Hi,

    What is actual syntax for ecad_hint.map file?

    #
    map_objects_by_name->
    ECAD_NAME "????"
    ECAD_ALT_NAME "????"
    ECAD_TYPE "????"
    MCAD_NAME "????" ----> Creo Converts automatically.
    MCAD_TYPE "part"
    MCAD_LAYER "????"
    END
    #

    I am setting up Creo for data translation to ECAD. But i see there are some glitches. Please help me out.
    Ashok Kumar. P

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •