Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    I just got a new machine with Vista64 ultimate on it. installed our copie of Wildfire 4 and every thing was fine. Today I get a window on startup that says:

    "No write access to c:\Program files\proeWildfire4.0\bin\

    Please choose another startup directory for trail creation."

    I can choose any other folder on the drive and it will work, but it'll give me the same error next time I launch pro/e. I've tried removing the read only status of the wildfire 4.0 directory, but as soon as you close the window, if you go to properties it's still read only.

    Anyone know how to fix this?

    In general where should the trail file go? or the config.pro file for that matter?

    thanks

  2. #2
    Use a desktop icon (shortcut) to start Pro/E. Then you can change the startup directory of the icon (RMB/properties) to your working directory. I always redefine the user variables TEMP & TMP to the same place (C:\temp) & write trail files there. I also modify the Pro/E startup batch file to purge the temp dir so it doesn't fill up with trail files.

    Config files get read automatically in 3 places:
    loadpoint/text directory (also config.sup goes here)
    $HOME directory
    startup directory

    You can have more config.pro files where ever you want but you have to load them manually. I have one in every project directory for any special settings that project needs. I use a mapkey to load it as soon as I change the working directory.
    PTC quality philosophy: We've upped our quality standards. Up yours.

  3. #3
    Thanks. I tried creating a "temp" folder on the C drive at c:\program files\Temp" and it tells me that there is no write access to that folder either and asks me to choose another directory. Seems every folder I create defaults to read only status no matter where I create it. I click off the read only click apply, but it is right back to read only if I check properties again. I know this was a bug in XP which I never learned to get around. But Vista too? I don't know what to do. I can't get it to automatically start from any directory which means that I cant have it boot with a start part or config.pro file automatically. I have been working with Pro but its frustrating to have to go through these steps every time I boot up.

    Any ideas?

    thanks

  4. #4
    Do you have Administrator rights with your login? It is not exactly a safe way to run but that is how most people set up their PC's. If you do & you are still getting no write access you definitely have a windoze problem. You need a sys admin to straighten it out of a well placed bullet.
    PTC quality philosophy: We've upped our quality standards. Up yours.

  5. #5
    I have admin privileges. I can copy files into the install directory but proe still gives me the error when it boots up. Interestingly I created a temp folder at c:\temp to try out your suggestion. While the folder was there proe gave me the can't write error. I deleted the folder with out changine the path to it in the short cut on my desktop and proe booted fine but started putting it's trail.txt files on the desktop.

    thanks for your help.

    Edited by: Micr0

  6. #6
    The key it seems is to right click on the shortcut and select "run as administrator". solves the problem

  7. #7
    dr_gallup,


    How do you change the TEMP and TMP variables? I'd like to define them to write trail files to a specific location. Thanks.

  8. #8
    Why dont you use the config.pro option
    trail_dir my_trail_folder_with_path
    and point it to a folder with write permission (outside the program files folder ) ?
    ProE doesnt need administrator privileges to run.

  9. #9
    Quote Originally Posted by CRang72

    dr_gallup,


    How do you change the TEMP and TMP variables? I'd like to define them to write trail files to a specific location. Thanks.
    RMB the My Computer icon on your desktop. Pick the Advanced tap. At the bottom is a button Environment Variables.

    Under User Variables either create or change the Variables TEMP & TMP. I set them both to C:\temp\temp.

    Then in config.pro I set
    trail_dir $temp
    PTC quality philosophy: We've upped our quality standards. Up yours.

  10. #10
    I too got an error message like that on win 7 machine running WF5. Following are the steps to fix this issue
    1. Navigate to the place where you have installed proe. For me it is C:\Program Files\proeWildfire 5.0
    2. Right click on the folder proeWildfire 5.0 and go to properties. On the window click on the Security tab.
    3. Under group or user names you will find a list of users. Eg. Administrators, users etc...
    4. Select Administrators and in the below Permission for Administrators box make sure you all ticked under Allow and nothing is Deny.
    5. Do the same thing for Users
    6. Click Apply and OK at end
    7. Restart ProE

    Enjoy

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •